Inventory Webhook not sending?


I am currently trying to set up an inventory update webhook for my test account. I have created it through the graphql endpoint and when I make the get webhooks api call I can see that the webhook is registered properly.

When I update the available inventory in the quick edit view for a product, it does not appear to trigger the webhook.

For context, we currently use this webhook to populate a custom dashboard in realtime. With the v1 api we were grabbing every product in our system every 20 minutes and just getting the inventory from there. With the new graphql api, this is not really a possibility with the credit system so I figured I could rely on the inventory webhook instead. Since I need available, not just on hand (which is inventory in the webhook response right?), I am planning on hitting the product api to get available when we receive the webhook.

I am not super familiar with the whole ecosystem - first time using Shiphero and being involved in fulfillment. Are there any gotchas or things I should be concerned about with this new strategy as a replacement for our old logic?

This is the request_id from the registered webhook: 5f4ccca0bda8e17cb5f05bf5

Hi @kevin
Thanks for those details!
For now I created a record at
We are working on a fix for this, but for the time being this record fixes the issue.
Let me know if you receive the webhooks from now on.
Thanks in advance!

@tomasw thanks for setting that up! it appears that the webhooks are still not sending. I just set up another webhook for PO updates and that appears to be working just fine. I changed the inventory via the quick edit, as well as editing a PO with that product to be received. Neither triggered the inventory update webhook. Should it be immediate? also just tried deleting and recreating the inventory webhook via graphql mutations

Hi @kevin
Thanks again for those details, we currently have an engineer working on this.
I will let you know as soon as we have an update about this.
Thanks again!

Hi @kevin
A change for this was implemented today, you should be receiving Inventory Update webhooks now.
Let me know if you still have trouble with them.
Thanks again for the patience!

@tomasw Thanks so much! we’ve been running everything in production for a few days now and everything mostly seems to be running smoothly.

There is one sku that was updated today that might not have sent through an inventory webhook though: P15001-02-C. Would you be able to let me know when the last webhook sent for that sku was? and what the availability was? I know that sku had a webhook sent earlier since looking at our own database it was updated to 49 at 2020-09-10 14:28:29, but it should have been updated again down to 48 later in the day.

We have a non kitted version of the above sku that should have the same inventory: P15001-02. This sku was updated later in the day at 2020-09-10 17:24:55, so i’m assuming the webhook for the other sku should have been sent around that time as well

Hi @kevin!
I’m seeing some 404 responses from yesterday, for example:

At 2020-09-10 15:40:50
Status Code:404
Message: Tunnel .io not found

I edited the URL for security reasons

But I’m not seeing the product with SKU: P15001-02-C in that account at
Is it for the same account mentioned above on?:

Any advice welcome!

@tomasw sorry, should have clarified this is a different account. This is the id of the webhook itself: QXBpV2ViaG9vazoxNjE1OTA1

Thanks for clarifying that @kevin!
I’m seeing this as the last webhook for that product:

"data" : {
		"webhook_type" : "INVENTORY_UPDATE",
		"sku" : "P15001-02-C",
		"inventory" : "47",
		"backorder_quantity" : "0",
		"virtual" : false,
		"timestamp" : 1599844762.0409043
	"timestamp" : ISODate("2020-09-11T14:19:22.931-03:00"), 

Let me know if this doesn’t help.
Thanks again!

@tomasw good to know it was sent today and it’s still updating. Is there any way for you to know if a webhook was sent for when the inventory dropped to 48 yesterday? The issue is that I don’t think the webhook sent for that because though when I pinged the inventory api manually it was 48 at one point yesterday but it was out of date in our system that’s based on webhooks

Hi @kevin!
I just looked and it seems like two orders where shipped at the same time using bulk ship, this is:

09/08/2020 07:30:16 AM Order 1
09/08/2020 07:30:13 AM Order 2

Both on the same Batch.
So the reason you did not see two Webhooks might be because the change occurred practically at the same time, so we sent the 47 and not the 48
Let me know if this doesn’t help.
Thanks again!