Manage order date and time

Hi,

I think somethiing’s wrong with Dates and Times when creating orders via the API. When an order is created, I also need to set the time when it needs to be fulfilled. So, I’m using the field hold_until_date that does that.

We are using timezone “America/Santiago” (UTC -4). And this works fine when we push an order with a specific date. For example, we push an order with date “2022-08-30T20:00:00.000Z” and in Shiphero the time is shown correctly: “08/30/2022 04:00 PM”.

The problem is that the order’s “Hold Until Date” and “Hold Until Time” are not working correctly, the times that are being set are not aware of the timezone, so, with the same example, if I put hold_until_date with the value of “2022-08-30T20:00:00.000Z”, in Shiphero App it shows “08/30/2022 08:00 PM”, that is not what I expected. It has to be “08/30/2022 04:00 PM”.

Maybe am I missing some settings?

Update:

I tried sending the orders with local time, i.e. “2022-08-30T16:00:00.000-04:00”. And, again, the order date is set correctly, but the order hold_until_date is showing “2022-08-31T00:00:00+00:00” and I don’t even know why.

See screenshot:

mutation order_create:

PS:

If I send the order with hold_until_date in local time but without the timezone, (i.e. “2022-08-30T16:00:00”) it seems to work, but of course this is not an expected behaviour as it is not following the ISO 8601 time format.

Hey @marioreinike,

Thanks for reaching out!
Going to start looking into this; I’ll have an update for you shortly.

Best,
RayanP

1 Like

Hey @marioreinike,

I do believe that this issue will have to be escalated to our Engineering Team to be fixed. I’ll keep you updated here as the updates come in. Thank you for bringing this to our attention.

Please let me know if you have any questions or concerns!

Best,
RayanP

Ok, thanks! :+1: :+1: :+1:

1 Like