Generate snapshot mutation not sending data to post_url address


I am trying to send a generate snapshot mutation, but am unable to configure it to get data from the s3 URL so need to add the post_url as it says to in the docs:

The graphQL request id is 5f46b16fa982683af3f3a277 – One odd thing is that i sent the two required fields in the docs as post_url: ‘xyz’ and post_url_pre_check: false , but the request is changing the precheck and returning the post_url: ‘xyz’ with post_url_pre_check: true

Any idea why the call is not sending the snapshot data to the URL? I can send a simple sample JSON POST to that URL with postman and it gets picked up. I also queried the snapshot and it says status: success and gives the s3 snapshot_url, but that snapshot JSON was never sent to the post_url

Hi @Orion
Thanks for all those details, I’m currently checking this with an engineer to make sure its working correctly.
I will update as soon I have a response about this.
Thanks in advance

Hi @tomasw – any response on this yet? Thanks

Hi @Orion
This should be working now, an engineer recently deployed a fix for it.
Let me know if you still have any issues with this.
Thanks again!

Hey @tomasw – this still isn’t working for me. Here is my request_id for generating the snapshot: 5f52bc1e7da7c3bc487be8a7

and here is my request_id for querying the snapshot after a success: 5f52bd8f6dfb67f54002f2b6

The post url precheck is staying as false now but the JSON data from the s3 snapshot url still isn’t sending to my post_url. Can you please keep looking into this?


Hi Orion
It seems to be working for me, I tried it on my test account and I got the information.
You should be getting something like this:

    "snapshot_id": "5f52f7008fa9679909db7445",
    "job_user_id": "VXNlcjo5MTIz",
    "job_account_id": "QWNjb3VudDo2MzM0",
    "warehouse_id": "V2FyZWhvdXNlOjEzMTc0",
    "notification_email": "",
    "post_url": "",
    "status": "success",
    "created_at": "2020-09-05T02-25-04+00:00",
    "enqueued_at": "2020-09-05T02-25-04+00:00",
    "updated_at": "2020-09-05T02-25-05+00:00",
    "snapshot_url": "",
    "post_url_pre_check": false,
    "customer_account_id": null,
    "email_error": null,
    "post_error": null,
    "error": null,
    "snapshot_expiration": null

Not the JSON with the snapshot, but this JSON that has the snapshot_url.
Any chance you might be expecting the snapshot maybe? I also checked our logs and it seems that the Posting Notification was successfully sent at 2020-09-04T22:14:20.938Z for this snapshot.

Let me know if this is not the issue and we will keep on investigating on our side.
Thanks again!

Hi @tomasw,

I tried again with this request id: 5f5a89583f1eff55a18209bb

It is fine if it sends a JSON containing the snapshot_url, but this still doesn’t seem to POST anything to the post_url. Here is a response after querying the snapshot_id for reference:

“data”: {
“inventory_snapshot”: {
“request_id”: “5f5a89a3656221506877d4c5”,
“complexity”: 1,
“snapshot”: {
“snapshot_id”: “5f5a89585fa08c3e3beca701”,
“job_user_id”: “VXNlcjo3OTAxNQ==”,
“job_account_id”: “QWNjb3VudDo0ODkyOA==”,
“warehouse_id”: “V2FyZWhvdXNlOjU1ODY4”,
“customer_account_id”: null,
“notification_email”: “”,
“email_error”: null,
“post_url”: “ (URL redacted)”,
“post_error”: null,
“post_url_pre_check”: false,
“status”: “success”,
“error”: null,
“created_at”: “2020-09-10T20:15:20+00:00”,
“enqueued_at”: “2020-09-10T20:15:20.777000+00:00”,
“updated_at”: “2020-09-10T20:15:49+00:00”,
“snapshot_url”: “ (redacted)”,
“snapshot_expiration”: null

Doing a simple POST in Postman with any JSON, the URL i put in the post_url field will pick up the data, but it is not working here. I would think that once the snapshot is marked as successful, it will send POST to the post_url that contains a JSON of the snapshot_url. Any more ideas?


Hi @Orion!
I do see on our logs the Posting notification log, but I just requested one of our engineers to check this out and see if he could provide a better insight about this.
I will let you know as soon as he responds
Thanks again