Why is the hook not called properly?

Hello, guys!
I’ve developed webhook to update the shipment, in order to make this webhook work correctly, according to the guide, I’ve registered with the webhook_create mutation with the graphQL.
I first registered under the client account but it didn’t work so I tried with the 3PL account.
That didn’t work either. I checked the webhook list and found my endpoint was registered correctly.
The request id for the 3PL account is ‘60531696bd7d7587169ba85c’ and the request id for the client account is ‘6053797f1fb54150c79823bb’.Before registering my endpoint, I tested it and it seemed to work well. But when I make a shipment (by shipping a pending order at shipping.shiphero.com), the webhook is not triggered.
I’d appreciate any assistance to fix this problem.

Hi @Wei
Welcome to our community! And thanks for those IDs!!
That is correct, the Webhook needs to be registered on the Client account
It seems like those two requests_ids are for the 3PL account. You will need to register the webhook on the Client account by including customer_account_id on the payload of the Mutation
Let us know if that still doesn’t work
Thanks in advance!

Hi @tomasw , thanks for the update. Wei’s part of my team so I’m going to jump in here.

Can we use our 3PL access token and just set the customer_account_id for all our customers when registering the webhook (as we need to set it for all our customers)? Or do we need to have an access token from each of our customer accounts?


We tested this and it looks like we can use our 3PL access token with the customer_account_id. So no need for an access token from each of our customer accounts.