Can not get access token "Unauthorized"

Hello there,

I can not pass the very first authorization API and I am 100% sure that I input the right username and password of the platform
I tried on postman and command line and both are not working… Is there something that I missed? Or maybe my account authority level is too low to access API?(my account was created by my colleague so not sure about this possibility)

curl -X POST -H "Content-Type: application/json" -d '{ "username": "", "password": "password" }' ""

{"message": "Unauthorized"}

What is your email? I can check.


You have permissions, and the email is a user. Try posting the following to

“username”: "",

“password”: “_________________”

If you can get into ShipHero with the credential, it shoud give you a token

Same error…

Hi @vegeman !
Our apologies for the delayed response about this.
Please try now and see if it works
Apparently, the user was blocked but Auth0, we unblock it and you should be ok now.

Please let us know if that doesn’t work.
Thanks again!

Hello @tomasw ,
Thank you for your reply but I just try it again and get the same error…

Did you change your password lately @vegeman?
If that is the case try with your previous password and see if that works

You could also generate a 3rd Party Dev user (with another email, for example,
Getting Started – Developer Resources | ShipHero

Thanks again!,

Yes I did. None of my previous password works… Yeah I known about 3rd party feature but I still want to make API login fix.

Your support team just open a sandbox environment for me and I can login properly by the testing account. Seems like something goes wrong on my account or authentication data mapping? Could you help me to look that up please? Thanks!

Hello @tomasw , we are facing the same error message “Unauthorized”, could some help us to check if the account is blocked by Auth0?

Hi @LuisBuff !
Try now and let us know if it doesn’t work.

Hi @tomasw
There is some quota of login requests?, after a while we have gotten the same error message again

Reviewing the documentation it is recommended to Adding a Third-Party Developer and use the token and refresh token that is obtained through the following link( )

I have tried to generate it with my sfapp(shiphero fulfilment) account but I have not been able to generate it

Hi @LuisBuff
We can definitely help you with that!.
Please email us at that way we can share refresh tokens or discuss sensitive information if needed
Thanks again!

Hello @tomasw , we are facing the same error message “Unauthorized”, could some help us to check if the account is blocked by Auth0?

Hello @LuisBuff!
I’m looking into this.
I will let you know as soon as I have an update.
Have a nice day!

Hello @LuisBuff!
Could you check if it is working now?

Hi @tomasfd,

I am getting the same error. Apparently is a throttling error, since it occurs when many requests are sent to the /auth/token endpoint.


@tomasfd We are having the same issue when trying to retrieve access token for an account that otherwise works well via normal login. Can you advise?

Hi @kator
I will be happy to look into this further. Please send a request_id so I can pull some details. Thanks in advance.