Configuring Webhooks - To Get Shipment


I want to get the shipment details from the Shiphero, so to get the shipment information I have register the webhook “Shipment Update” through GraphQL API, but when evenever the shipment created in shiphero I am not getting anything on the endpoint url,

Register the Webhook “Shipment Update” :->
mutation {
webhook_create(data: {
name: “Shipment Update”,
url: “
}) {
webhook {

And I have checked as the the webhook register or not, and i can see its registered,
“node”: {
“id”: “QXBpVjE1Mjky”,
“legacy_id”: 16112122,
“account_id”: “QWNjb3VA==”,
“shop_name”: null,
“name”: “Shipment Update”,
“url”: “”,
“source”: “api”

So, My question is, why I am not getting when the shipment happened/created in shiphero,

If above api not worked, then I want to know which GraphQL API should I used to get the shipment information from Shiphero


I ran into a similar issue when first integrating with Shiphero. In our case it was during testing, and had to do with how we were creating the shipments in shiphero. If the order is marked as shipped via the webapp (app.shiphero) then we did not receive shipment webhooks. If the order is marked shipped via endeavour (endeavour.shiphero) then we did receive the webhooks.

Hi @Mangesh!
Is there any chance you could provide me with the request_id ?
That way I could check the account to see if there is a setting issue or something else.

Thanks for adding that @scott ! yes that might also be an issue, because the webapp had a legacy code and was not being updated lately, that is why we recommended avoiding shipping from there. We currently deprecated that feature (a few days back) in order to avoid that confusion

Thanks in advance!

Hi Tom,

This is the “request_id”: “5f2152baad58e924bf903041” please check and let me know.


Hello, we shipped order via This is the order:

Hi @Mangesh @veraioele
Did you received the webhook now?
Thanks again for the info and the patience while we look into it

Hi Tom,

Yes I am able to see it now. What was the issue.



Hi @Mangesh
It appears that there were some data missing for that account, so when the webhook triggered it had an error and was not able to be properly sent, once I added the data I manually triggered and the issue was solved.
I changed that manually so it should not be a problem anymore for this account, while we work in the root issue so it doesn’t happen in the future for other accounts.
Thanks again!