Inventory Snapshot - JSON coming back with everything "Invalid"

Hello, we have been doing inventory snapshots regularly as part of our process, but recently the JSON is coming back with everything stating INVALID for Vendor ID, such as:

and when we try to parse the JSON it states “Unexpected end of JSON input”

Example Request ID: 6285209a3ccc64b9d4851da4

Example Snapshot ID: 6285209a3ccc64b9d4851da6

EDIT: It randomly started working again now.

Hello @atlatin!

Thanks for reaching out.

Have you gotten any new errors since it started working?

Kind regards,

Hello Tomas,
It appears to be working still with no errors. It seems we had to delete “Unassigned” product locations from all products since it was empty and then it worked. I’m not sure if perhaps there were just too many SKUs in “Unassigned” empty bins since it seems that ShipHero automatically creates that location for all Shopify products. Thank you!

1 Like

Hello @tomasfd,
It seems I spoke too soon. The error is happening again. When we try to parse the JSON we get “ERROR: Unexpeected end of JSON input”

Example Request ID: 628e854933932bccca7b013a
Example Snapshot ID: 628e854933932bccca7b013c

Do you know why this may be happening?

Hello @atlatin!

I just copied the whole file, and it seems to be parsing ok for me.

Is there a way for you to retry?

Kind regards,

Hello Tomas,
Very strange. I retried and this time it worked but it wasn’t working for the past 2-3 days. I’m not sure why that is happening periodically.

Hello @atlatin

Please check your inbox!